[SOLVED] "requested database object could not be found"

So I see this error message when I try and tag pages

21

E.g. this screenshot was taken from when I pressed ‘t’ to tag a page, and selected the tag. It also happens when I create a new tag.

I’m using firefox on MacOS

Georgia

Okay so any answers on this? I’ve been using Memex a lot, mainly with tags… it’s awkward not being able to tag stuff for work anymore

If it helps the error I’m now getting is “r.Dixie is not defined”

hey @geoiac,

Sorry have answered this one in a separate thread.
There were actually 2 bugs hidden, we fixed the first one with 1.5.1 and are in this very moment in the mode of fixing the second.

By tonight or latest tomorrow a fix will go out.

Sorry for the inconvenience.

This should be solved with 1.5.2. :tada:

Still happening for me with extension 1.5.3 in FF 72.0.2 on OSX 10.15.2. Unable to categorize or tag anything new.

Also keep getting a notification from the extension that disk space is low and I might start losing data but there is > 150GB free. Assuming this has to do with FF localstorage limits and eviction policy; why not request the “unlimitedStorage” perm?

@tautologistics

I think you are running into a different problem. In your case the quota of data is exceeded.
We do ask for “unlimitedStorage”, however Firefox does not fully adhere to this specification.
Their implementation allows for up to 2GB of data to be stored per extension/domain-origin.

It’s a real bummer and we don’t have a solution yet. We already disabled the screenshots on Firefox to make sure people don’t use too much data, so 2GB should last for very long (roughly 2 years).
I’ll check in with our devs and ask for a command you can run to delete all your screenshots, that should free up some space again.

Yup, just checked and the extension storage has a 1.1GB sqlite file and the “.files” dir is 900MB.

I have not been using the extension for anything close to a yearso I am wondering if thumbnails created before you disabled them in FF are still there. Is there a way to purge existing thumbnails? Also, is there a way purge indexed content that does not have references (i.e. tags, notes, stars, etc.)?

Figured I’d ask before digging into the sqlite DB directly…

@BlackForestBoi thank you so much – sorry for late reply, I was away. It all works again now :slight_smile:

I have a similar problem since a few days with a message stating “Low storage space. Data might be deleted. Click to backup & free space.” I assume it’s also because I’m hitting the 2GB hard limit in Firefox.

  • Where do I find the info on how much space has been used by Memex in FF?
  • Where can I delete screenshots to make room? (Not that I want to …)
  • Anything else I can do?

Thanks!