[SOLVED] Unable to authenticate or restore password

Hi
I’m unable to authenticate in my Memex account to use a backup feature that I paid for.
Whenever I’m attempting to authenticate, I’m being redirected to the same page: https://worldbrain.io/community/myreferrals/
Whenever I’m trying to reset my password, I’m receiving incorrect link: https://worldbrain.io/community/lost-password/?key[errors][no_password_key_update][0]=Could%20not%20save%20password%20reset%20key%20to%20database.&&id=874

Please fix this so I can use the paid backup feature.

My username and e-mail are the which I’m using on this forum.

Thanks.

1 Like

I’ve tried signing up several times (I want to pay to support the project, even if the backup features don’t work yet), but similar results. The form submits, but no email is ever received, and if I try anything like reset password, it looks like the account doesn’t exist. I’ve tried troubleshooting a little (alternate browsers without script blocking, etc.) with no luck.

@dees

I think this should now be solved. The new account system has been rolling out last week.

I just tried again, but no luck, still looks like my account was never created on worldbrain.io

The extension itself does show an account info tab, with my email address visible, but it doesn’t obviously seem to be connected to anything else yet. The links from the extension ‘upgrade’ modal don’t open anything.

Same here.
FF 68.3.0esr (64-bit)

Did you all reset your passwords? @dees since you were able to use the sync I assume you were able to do that already?

You say in the extension the little payment window immediately closes again? Is there any error message in the background console of the extension or the tab this happens in?

Nope, it seems like I have an account attached as far as the extension is concerned, but not on the website. I’ve never seen an account related email, for example.

There’s nothing I would describe as a payment window, just the “upgrade” dialog with per month or per year options… click on either of those does nothing. Browser console error output is as follows:

Could not load payment provider as external script is not currently loaded. options.js:1:875371
TypeError: t is undefined
options.js:367:193089
TypeError: t is undefined
options.js:367:193089
TypeError: this.userSubscription is undefined
options.js:347:12596

If I access the same dialog from the “account info” page I see the following:

Loading failed for the <script> with source “https://js.chargebee.com/v2/chargebee.js”.
options.html:1:1
Content Security Policy: The page’s settings blocked the loading of a resource at https://js.chargebee.com/v2/chargebee.js (“script-src”).

The account info page just shows my email address and the “manage subscriptions” button that opens that dialog. Nothing on the website itself reinforces the notion that there’s an account saved on a server anywhere, no emails sent when attempting registration or password reset, the failure message says no such account found, etc.

This one is fixed now on FF but will take a few days to be released to the Chrome Users due to Chrome’s review process. We are considering to move the Extension out of the Chrome Store into self-distribution because of those issues. It’s not suitable to let users wait 3-7 days for simple fixes to go out.

Great! It looks like the subscribe UX could use some polishing up. I wasn’t able to complete a transaction with paypal. The console message said something about script not being able to close a window that wasn’t opened by a script. Paypal also seemed to be having some intermittent trouble that would clear up on a re-try, which could well be unrelated but it happened multiple times, implying something strange about the embed code or configuration.

After a few attempts I went ahead and tried entering card info. Autofill via lastpass wasn’t perfect, but checkout completed fine and now I have auto backups enabled, hooray!

Thanks so much for noting this. These are the small, but important, annoyances that are usually hard to uncover for us, so any tips like these are super appreciated :pray:

I investigated this and it seems to be problem with Paypal injecting more scripts that are not clearly defined in the Content-Security-Policies of the extension. Will try to update these in the coming releases to make it smooth.

@BlackForestBoi glad to hear it!