[SOLVED] I can't register

I’m not able to register for an account on https://worldbrain.io/community/myreferrals/

When I go through the registration process it returns me to the same page, and does not provide any feedback about whether the account has been created. When I go to log in, it doesn’t recognize the account. Using the “reset password” flow, I get a message saying that account doesn’t exist.

I tried multiple types of user names to make sure mine wasn’t taken, used very strong passwords, and tried the process on Chrome, Firefox, and Safari. I’m on Max OS Catalina.

It appears others may have had a similar issue from 3 weeks ago. If this is the case you should really put a warning up on your site so we don’t all waste our time.


+1, I’m having the same issue.

Thanks folks for dropping by with this. Sorry for the troubles.
Its a known issue and super annoying. A fix is already in the making, we’re almost there.

I’m still having the same problem, I had to start a new account because I could not access my old account.

With the roll out of our new account system this is solved. For anyone who had account before, you need to reset your password first and then login on website or extension.