[SOLVED] How to restore on a new computer & then back up?

Hey @mydjtl!

First of all welcome to the community forum and sorry it had to be under these circumstances :slight_smile:

May I ask what made you determine that it failed? What did you expect and didn’t happen? Any error messages?

So usually it works when going to the settings > backup & restore > restore
If you have done a backup on another device via the downloaded “Memex Backup Helper”, there should now be a folder on your system called “backup” in the folder you selected.

This “backup” folder needs to be copied over to the new compute. When clicking on “Restore”, you need to pick the parent folder of the “backup” folder. I know its not really intuitive, we have an overhaul of the backup/restore workflow already on the map.

Once the restore is done, you start the “backup wizard” which should be the first item in the backup&restore settings page.
Once you have set this up it would just continue adding to the same folder as before, so your new extension is as if it was the old one.

Hope that helps!
Oliver

See here

CloudApp

and here

CloudApp

It looks like on many steps you have to press the buttons twice?
Also that there are bugs in the buttons of the upgrade process when you want to click on “pay now”?
It works for me so I wonder what went wrong.
When you click on it, does the tab start loading a new page?
Also what are the system specs you have?

Also: after you went to the worldbrain.io page, and then reloaded the “backup&restore” main page, did it then switch to the Automatic Backup enabled mode?

Unfortunately the last screencast didn’t upload properly.

If i restore and click google drive then login its stuck on this. It used to work. What do I do? Alos, I’m using opera browser on windws 10

Thanks for providing the screenshots. Unfortunately they are less helpful than I thought.
Mhh something we can try next:
Can you check what the console errors say?

I don’t know how that works in opera, but on chrome and FF it works on mac by pressing cmd+alt+j or right click on the page and go to “inspect” and then “console"

Can you try to get to that screen and then open the background console of that page and make a screenshot of the error output (ideally after a few minutes again in case there are no errors because it may get stuck longer down the line)

There is a second console you can check, the one of the extension itself.
In chrome you go to chrome://extensions then enable “developer mode”, go to “memex” and find the “background page”, and then on the tab “console”.

Sorry for all the troubles. We are currently finishing up a testable prototype for the mobile apps and sync, which has a higher priority so we can test a complex feature in real life scenarios as soon as possible. We know there are quite some issues with the backup process which we are in the process of fixing. It’s one of our top priorities. After the mobile apps we are working on those (UX) bugs people experience in a couple of places, including the backups.

There are still some open questions from the last message that would really help me to locate some of those bugs and UX issues more. I would be thankful if you had the time to help me with some more information on those questions.

1 Like

I decided to switch to Edge Beta. Still not working but it seems like it might be possible. See screen recording. Can you help?

  1. https://cl.ly/8d785d
  2. https://cl.ly/a755aa

I was able to fix it. New problem now. I already paid for auto backup but keeps asking me to pay since i can’t login to the shopping account.

What made it work for you? And what exactly didn’t work on Edge?

Yeah we currently have some issues with out account system. New website will be up in a few days and then you can use it again. Will provide you with a free month of auto backup once thats done to make up for the hassle.
Sorry!

OK. Not sure what worked but still barely syncing since i can only do it manually.

UI: restore (From Google Drive) stalled at 0%

Is there anything I can do on my end?

How can I verify that the backup TO Drive is actually working (from another browser)? I haven’t been able to find any file that looks like it’s been created by Memex.

Ok, it turned out to be Firefox’ tracker blocking that interfered with the backup. Resolved now. Memex could do a much better job of detecting what went wrong and informing users though! Before I realized what the problem was, the backups often looked like they were successful which is even worse than just looking stuck.

I still can’t login to setup automatic backups. Is there a fix? Will probably request a refund soon. Its been more than a month

Hey @felixyz ,

indeed it’s on our highest priority list to be fixed to show better notifications in case something fails.
We are right now heavily working on overhauling our instable auth system and launching the mobile app.

We hope to have it fixed soon.

hey @mydjtl

I am really sorry for that not being resolved soon. We were running into a couple of blockers with the mobile app development (which entails an overhaul of our auth system)

We are short before releasing those. I am happy to do a refund or give you 3 months of free premium upgrades once we launch the mobile app , as a reparation for the hassle you had. Really sorry :frowning:

refund please [email protected]

Hey mydjtl, this is a project in beta and under heavy development. You can follow all activities first hand.

My suggestion: You can feel proud to be one of the first facilitators of this truly great project. Without people like you, it won’t be possibl at all. – Be patient, and all your wishes will come true and all issues be fixed, one day. Just not today. :slight_smile:

Hey! Yes let me do it immediately.

Thanks @Martin for your support here :slight_smile:

Indeed, I was testing all the updates today. We are launching it almost certainly before the new year.

but of course, I’ll refund you @mydjtl!

Until next time hopefully when all works again.

I’m willing to switch back to chrome if it works on that platofrm. Edge dev still not ready ?

So looks like I can login using chrome beta but it doesnt recognize that I paid a year in advanve already. Can you update my account?

FYI, I can login here: https://getmemex.com/

But not here, https://worldbrain.io/community/myreferrals/

Hey @mydjtl!

We just made a big update to our account and billing system, and the extension.
Sorry it appears the 1.5.0 update to the extension is stuck in the review process on the chrome store.
You’ll be able to login and use the backup mechanism once that is done. Judging from the last time, it took about 48h, so probably by tomorrow latest.

Btw we are also releasing the mobile app for iOS and Android in the next few days. If you’re interested to become a beta tester you can head here: [NEW] - Testing Memex Mobile App & Sync