Disk Space Warning

I frequently see the following message:

:warning: You’re almost out of storage space. Your browser may delete Memex data

Due to the browsers policy to evict local storage when space gets low it might happen that your Memex data gets deleted. Free up disk space and make sure to backup your data for the worst case

However, when I look at my disk space usage, I’m not low at all:

df -h
df: /run/user/1000/doc: Operation not permitted
Filesystem      Size  Used Avail Use% Mounted on
devtmpfs        7.8G     0  7.8G   0% /dev
tmpfs           7.8G  223M  7.6G   3% /dev/shm
tmpfs           7.8G  2.4M  7.8G   1% /run
/dev/dm-2       225G  136G   78G  64% /
tmpfs           7.8G   24M  7.8G   1% /tmp
/dev/nvme0n1p2  976M  233M  676M  26% /boot
/dev/nvme0n1p1  200M   22M  179M  11% /boot/efi
tmpfs           1.6G  5.2M  1.6G   1% /run/user/1000
/dev/sda1       3.6T  1.8T  1.7T  52% /run/media/pregan/backup

Am I missing something?

Are you a Firefox user?

Firefox has a maximum capacity per extension of ~2GB (even though they communicate infinite storage, super annoying). That may be the case for you.

How many items do you have in the database right now? (check via “import” settings in Memex where it calculates items in the DB)

I am a Firefox user.

I have 17393 items in the db. My backup on the local disk is 2.2 GB, so that tracks with your info on FF’s 2 GB limit.

Is the work around to use a different browser? I do wish to keep using Firefox, but I can live with Chrome for a while.

Just saw your update on my other thread. I will be removing the images folder! That could help.

Chrome does not have these limitations, no. So yeah the workaround would be using Chrome.

With 17k items it usually should not cause 2.2gb of data. I have 50k pages in my Memex and 1.7gb.

I removed the images directory and it dropped down to 1.8 GB. Still a bit high, but I imagine it’s indexing my work chat tabs, which I could blacklist to save space. Those are searchable in their direct interfaces.

This info is helpful! Thank you! Loving this product, so I subscribed about a month ago.

1 Like

Thanks so much!

Your support is what lets us keep going.
As you can see in our vision posts, we don’t take VC money so every person who funds this project helps us to stay independent.

So thanks for sticking with us even if the offline-first mindset has quite some hurdles to walk through :pray:

Just curious, I found browser.sessionstore.dom_storage_limit in about:config. Which was set to 2048, if I changed this setting, would that help? It seems not directly related to the extension settings, but was something that caught my eye.

Glad to help. I like to read a bunch of things and frequently ask myself “Where did I read about $SUBJECT?” and now I have a tool to help me find it again.