Backup not working

We just released an update to the backup helper app that max fix this issue.
Here you can get it: https://github.com/WorldBrain/local-backup-server/releases/tag/0.5.0

Since we can’t reproduce it on our side we rely on your reports.

Hey Oliver, I tried the new backup helper app, and still the same problem. I made sure to turn off my Little Snitch firewall, but that didn’t help. There is no connection.
Could this have to do with App Translaction?

Do you have a version of helper with debugging turned on?

Also, why did the helper just balloon to a huge filesize? (near 1GB)

Thanks

Running backup helper 0.5.0 on Linux (Debian 10)

Only one image per post huh, ok, here goes 3 posts

I do have something running on 11922:

Still no backup joy:

Also: I don’t think this is related but my account says cancelled even though I just subscribed to the Pro Pioneer tier and am still on the 14 days trial.

Also a big thank you for building this, very inspired by your interview with Tiago today. In terms of quality you have a little way to go but bravo for pushing in this direction (and the way you push for openness and freedom!)

Can you identify what is running on this port?

Also: I don’t think this is related but my account says cancelled even though I just subscribed to the Pro Pioneer tier and am still on the 14 days trial.

Yeah its an edge case that our system does not properly pick up right now when people cancel and then re-subscribe.
I delete your cancelled subscription. if you go to settings > my account > refresh subscription status it should show you the right subscription.

Still no backup joy:

We had an issue with our server which is now fixed and backup via google drive should now work again.

Great, thanks. Local backups are working now!

(it was the backup helper running on that port, now that you updated my account it works.)

I was hoping that would also enable me to set up sync with my mobile device but when I click on “Pair new device” I just get redirected to the account ugprade page (which also shows that I’m on the pioneer plan). The same is true when I try to enable automatic backups.

I’ll assume that functionality is still work in progress but in case something is still stuck on the account side here’s what it looks like:

Argghh!

Annoying :frowning:

I assume that because of the cancelling/upgrade process there are still some bugs.
Sorry we haven’t optimised for that use case so there may still bugs taht appear.

Can you try to logout, disable the extension, enable it again, login and try again?

Mhh this should not be connected at all.
Do you use google drive or the backup helper now?
Did you restart the backup helper at some point?

I was using backup helper and I did restart it a few times (I didn’t leave it permanently running).
The files got created in the directory I specified so that looks good. Haven’t tried a restore yet.

When I switched to Google Drive for storage (just to give it a try) it looked like the backup was created and uploaded successfully. But what file or directory am I looking for in my GDrive? I don’t see anything stored there.

I do switch between multiple google accounts (work and personal) but I didn’t see it in either one.

No problem, I’ve written enough software to know what that’s like.
You guys are doing great work so you have my support until you get everything sorted out.

I logged out and back and sync is running now, thanks for your help.

I’ll just file reports as I use this but if there are other ways I can help (I’m a bit more Ops-y than Dev-y) let me know.

@root

We FINALLY could reproduce the bug with the localhost not being available and fixed it in the release 0.5.2.

Let me know if that works for you.

@BlackForestBoi Yes! the backup server opens a connection and I can do a manual backup finally.

But my 14-day trial just ran out so I can’t test the automatic backup feature. Could you reset my trial?

Yes for absolutely sure. Thanks for sticking with us and sorry for the frustration it caused.
Done! Enjoy.

1 Like

@BlackForestBoi Well, manual backups work but the automatic backups don’t. See screenshot:

darn!
Good news: I can reproduce on Firefox, but not on Chrome.
Better news: If you click now “backup now” it should switch to the automatic backup. at least it worrks for me.

I’ll file the bug and get it fixed up, thanks for the report.

@BlackForestBoi Somehow it got restarted on its own, maybe after I restarted Chrome. Thanks

Hi everyone, and support team @BlackForestBoi

I’ve just signed up to the forum after installing Memex a few days ago. Everything was working fine - backup and all - but 48 hours ago the backup just stopped working.

What is the problem?

I go to the dashboard, click “backup and restore” and the page just won’t load. It hangs. I then try under “sync status” to click “backup now” and the page hangs. I try to turn on automatic backup, and again the extension tries to open the backup page. It just won’t work.

What have I done?

I’ve re-installed the extension with no luck - more than once. I am using Brave, but even when I installed on Firefox and restored from my last backup, the problem occurs there!

I’ve re-downloaded the memex-backup-heper (most recent version 30th June) with no luck.

The last backups made automatically before the problem occurred were only 10kb in size (compared to the very first backups of 300kb) but I haven’t had any problems restoring from my last successful backup when I’ve re-installed the extension. I am suspecting as I write that perhaps these small backups could be a part of the problem? Perhaps I should delete the few small ones and use a larger one? (Note: Memex doesn’t let me choose which backup I want to use so I wouldn’t know how to do that; you’d have to explain.)

I’ve registered here and browsed through this thread. I’ve taken previous advice to “inspect the page” and look at the “console” - I’ve uploaded the screenshot here. As you can see I have a lot of extensions, but I have disabled them one by one to see if any of them affected my ability to backup. Even with all disabled I still can’t backup. The only one I think could be an issue is the “user agent switcher” - I like to use Brave but set this extension to another browser for fingerprinting purposes. What do you think?

Overall I believe this is a bug so I hope you can help. I want to use Memex to start bookmarking again from scratch rather than sort through hundreds of old bookmarks. But I don’t feel yet that the system is reliable, so if I can’t backup easily, I don’t want to put hours in just to lose all the data. Also my plan is to bookmark and annotate rather than inspect and log every site I visit, so I’m not expecting to amass a huge local file.

I hope that this message and its responses will be of use to other members that might be having the same problem.

As a final note, I’m not very technical at all, so while you can use complex computing language, I apologize in advance if I write back with simple or obvious questions!

Thank you!

Thank you @netbox for your detailed description of your bug.
Sorry if you run into troubles.

It seems one of the recent updates has caused some troubles and you’re not alone.
It has nothing to do with the backup helper though - different bug than the OP

I’ve put this as a highest priority bug to investigate and fix in the next sprint.

1 Like

Thank you for your reply. Because I had done a little organizing work before realizing that I couldn’t back up, could you ensure that any update to the extension can be re-installed over the eisting extension, so that I don’t lose my data?

If that cannot be done via the Chrome store, what about providing the update via this site, or github, to download and install over the top?

Besides this, thanks for prioritizing the bug and I await further news on this thread!